The Downs School - It is currently not possible to make external calls in Teams – Incident details

All systems operational

It is currently not possible to make external calls in Teams

Resolved
Partial outage 30 %
Started 3 months agoLasted 6 days

Affected

Phone System

Partial outage from 7:11 AM to 8:03 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.